As you may have heard in the news, a vulnerability was recently discovered in OpenSSL, the software that is widely used to secure the exchange of private information on the web. Trove uses OpenSSL to protect the details of your user accounts, so as soon as we became aware of the problem we upgraded the software to close this vulnerability.

There is no evidence at all that the security of any Trove user accounts was compromised, so please don't be alarmed. However, we'd suggest that it would be a sensible precaution to change your password.

From the Trove login screen just look for the 'Click here to reset' link and follow the instructions.

If you have any concerns, please let us know.


----------

Tim Sherratt
Trove Manager